buy custom essays onlinebuy custom essays online

IPSec Tunnel Windows và Cisco Router
Parajumpers sale www.airbrushhenk.nl Parajumpers sale http://www.unifem.ch canada goose sale Canada Goose jas http://www.canadagooseoutlets.be https://www.gasinc.nl
Home » Hệ thống » LAN » IPSec Tunnel Windows và Cisco Router

IPSec Tunnel Windows và Cisco Router

I. Giới thiệu:
Khi cấu hình VPN Gateway-to-Gateway, 2 protocol được sử dụng phổ biến là PPTP và L2TP/IPSec. Ngoài 2 Protocol này, ta có thể sử dụng một phương thức khác ít phổ biến hơn: IPSec Tunnel mode. Lý do chính để dùng protocol này là thiết bị đầu cuối (non-Windows Routers) không hỗ trợ PPTP và L2TP.
Bài lab sau giới thiệu các bạn cấu hình IPSec VPN giữa Windows và Cisco Router để kết nối 2 chi nhánh. Bạn có thể cấu hình thông số tương tự để triển khai trên ISA Server với Router Cisco.
Sơ đồ:


II. Các bước thực hiện:
1. Cấu hình IPSec trên Server1
– Mở IPSec policy bằng GPEdit.msc hay Secpol.msc. Right-click->New IPSecurity Policy

– Next

– Nhập tên Policy: To Cisco Router

– Bỏ chọn Active… -> Next

– Để nguyên checkbox: Edit properties -> Finish

– Bỏ chọn Wizard, nhấn Add để tạo Rule mới

– Tab: Authentication Method chọn authentication bằng Preshare-key: nhatnghe



– Tab: Tunneling nhập IP External của Cisco Router: 210.245.20.1

– Tab: Connection Type chọn All Network connection hay LAN

– Tab: IP Filter List nhấn Add để tạo mới danh sách

– Nhập tên: Microsoft-Cisco (đây là danh sách chiều đi), nhấn Add

– Nhập IP Souce và Dest. như trên hình, bỏ chọn Mirror (tunneling không mirror)

– Chọn tất cả protocol

– Hoàn tất Filter list -> Ok

– Chọn danh sách vừa tạo

-Tab: Filter Action Nhấn Add

– Chọn negotiate, nhấn Add để tạo mode thương lượng:


– Chọn encapsulation là ESP, Encrypt là 3DES, Hash: SHA-1. Thời gian tạo key là 3600s

– Hoàn tất:

– Đặt tên Action tại tab General

– Hoàn tất Rule1 (Chiều đi)

– Tạo Rule 2 (Chiều về), làm tương tự. Thay các thông số IP Tunneling và Filter List tương ứng chiều về. Nhấn Add:

– Preshare-key: nhatnghe

– Nhập IP tunnel:

– Chọn All Network connection

– Tạo Filter list cho chiều về (hoán đổi source IP và destination)




– Chọn Filter Action tạo bước trên

– Hoàn tất 2 rule

– Chọn Tab General, Nhấn setting:

– Chọn thời gian đổi key giai đoạn 1 là 480 phút tương ứng 28800 giây

– Nhấn method xem các phương thức trao đổi tại phrase 1 (1)
(3DES, SHA, DH Group 2)

– Assign Policy vừa tạo:

2. Cấu hình Static Routing trên Server1
– Mở RRAS, enable RRAS

– Next

– Chọn Custom configuration:

– Check: LAN routing

– Finish

-Right-click Static Route -> New static route

– Nhập thông tin default route về ISP

– Hoàn tất:

3. Cấu hình trên Router 2

Trích:
hostname R2!— IKE Theo thông số (1)——crypto isakmp policy 1

encryption 3des

hash sha

group 2

authentication pre-share

lifetime 28800

crypto isakmp key nhatnghe address 210.245.10.1

!— IPSec lifetime

crypto ipsec security-association lifetime seconds 3600

crypto ipsec transform-set rtpset esp-3des esp-sha-hmac 

access-list 110 permit ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255

crypto map rtp 1 ipsec-isakmp 

set peer 210.245.10.1

set transform-set rtpset 

match address 110

interface S0/0

ip address 210.245.20.1 255.255.255.0

crypto map rtp

ip route 0.0.0.0 0.0.0.0 210.245.20.2

4. Kiểm tra
– Client1 ping Client2, nếu thấy giá trị TTL=127 là đúng (Mode tunneling packet client sẽ nằm trong tunnel nên không bị trừ khi qua các router External)

– Kiểm tra tại Server1, SA đã được thiết lập:


– Kiểm tra tại Router:

Kết thúc!

 

© 2012, Quản trị mạngNguồn: nhatnghe.

VN:F [1.9.17_1161]
Rating: 10.0/10 (1 vote cast)
VN:F [1.9.17_1161]
Rating: +1 (from 1 vote)
IPSec Tunnel Windows và Cisco Router, 10.0 out of 10 based on 1 rating

Other Posts in this category

No more posts found in this category
Post a Comment 

You must be logged in to post a comment.